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Introduction

Before You Start
The Toonz 7.1 Harlequin - Traditional Workflow Tutorial Workbook will 
guide you through the following steps of the traditional animation 
workflow:

• Setting up a Project

• Scanning Animation Levels

• Cleaning Up Animation Levels

• Painting Animation Levels

• Composing the Scene

• Applying Special FX

• Rendering the Animation

For more information about the software features used in this tutorial, 
please refer to the relevant chapters and paragraphs in the Toonz 7.1 
Harlequin User Guide.

Extracting the Tutorial Files
The Toonz Traditional Workflow tutorial requires the material included in 
the Toonz TW Tutorial Material.zip archive. 

The archive contains the following folders and files:

• The Backgrounds folder contains the bkg00.tif and overlay00.tif files.

• The Scanned Drawings folder contains the b..tif and bsh..tif files 
resulting from the scanning process.

• The Cleaned Up Drawings folder contains the b.tlv and bsh.tlv files 
resulting from the cleanup process.

• The Painted Drawings folder contains the b.tlv and bsh.tlv files 
resulting from the painting process.

• The Color Models folder contains the color_model.tif file.
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• The Final Scenes folder contains the scene files resulting from the 
composing and special FX editing sessions.
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Setting up a Project

Creating a New Project
When starting a new production you should define a new project by 
specifying its default folders and its default settings.

To create a new project:
1. Choose File > New Project. 

2. In the dialog that opens type Toonz TW Tutorial as the name of the 
project and set the following default folders:

• + inputs > My scanned images.

• +drawings > My drawings.

• +scenes > My scenes.

• +extras > My backgrounds.
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• +outputs > My renderings.

• +palettes > My palettes.

3. Click the OK button: the project Toonz TW Tutorial will be created in the 
Project Root folder of the Toonz browser.

Defining Project Default Settings
Choosing the Working Unit
Positions, distances and sizes in a scene can be expressed in several 
units of measure: inches, millimeters, centimeters and fields. 

In the Files > Preferences > Interface dialog you can set the following 
default unit:

• The default Unit used to display all measures in text fields, and applied 
when moving or changing the size of stage objects.

• The default Camera Unit used to display and define the camera size in 
the Xsheet > Camera Settings dialog. You can also express measures in 
an unit different from the default one by entering after the value any of 
the following units and abbreviations: in, inch,“, ‘ ‘ (double apostrophe), 
cm, mm, fld and field. As soon as the value is entered, it is converted into 
the default unit. 

If a value without a specific unit is used, it is supposed to be expressed in 
the default unit.

To set the default working units:
1. Choose File > Preferences > Interface.

2. Do the following:

• In the Unit option menu choose Inch as the unit to be used as default.

• In the Camera Unit option menu choose Field as the unit to express 
the camera size.
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Defining Camera Settings
Start to create the scene defining the Camera Settings.

The Camera Settings dialog contains parameters for defining the current 
camera size and resolution. 

The camera size can be expressed in any unit, but will be visualized in 
the default one chosen in the Preferences 

Once you define one of the dimension of the camera, Width or Height, the 
other is computed according to the resolution A/R value. A button at the 
bottom of the size text fields lets you mark which value is preserved 
when the A/R value is changed.

To define the camera settings:
1. Choose Xsheet > Camera Settings.

2. Do the following:

• Select the HD 720 camera from the list of predefined cameras 
available in the dialog.

• Set the Width to 12 fld.

Saving the Current Scene Settings as Project Default 
Settings
When you work on a scene you can save the settings you define for it as 
the project default settings. In this way all the scenes belonging to a 
project are created with the same settings, assuring the consistency of 
the production.

To save current scene settings as project default settings:
Select File > Save Default Settings: all the settings from the current 
scene will become the project default.
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Scanning Animation Levels

Before You Start
For this tutorial you can print the two TIF sequences available in the 
Toonz TW Tutorial Material\Scanned Drawings folder: b is the main 
character, and bsh is the shadow of the character.

Note: The size of the drawing image files is 297 mm x 210 mm at 250 
DPI, and should be printed on A4 paper without resizing them.

After scanning the drawings you can either save the scene file with the 
scanned drawings, or proceed to the next tutorial chapter Cleaning up 
Animation Levels on page 13.

To save the scene:
1. Choose File > Save Scene As.

2. In the browser that opens select the My scenes folder of the current 
project.

3. Assign a name to the scene and click the Save button.

Defining Animation Levels to Scan
Hand-drawn images must be defined first in the Toonz xsheet, and then 
acquired. Animation levels, made up of sequences of drawings 
considered as a whole, can be scanned, as well as other elements of the 
scene, such as backgrounds and overlays.
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To define the character animation level to scan:
1. Right-click the first cell of the first column in the xsheet and choose 
File > New Level from the menu that opens.

2. In the New Level dialog choose the following:

• Name > b.

• From > 1, To > 35.

• Type > Scan Level, as the level being defined here is to be scanned.

3. Click the OK button: an animation level named b and made of 35 
frames is created in the xsheet.

To define the character shadow animation level to scan:
1. Right-click the first cell of the second column in the xsheet and 
choose File > New Level from the menu that opens.

2. In the New Level dialog choose the following:

• Name > bsh.

• From > 1, To > 35.

• Type > Scan Level, as the level being defined here is to be scanned.

3. Click the OK button: an animation level named bsh and made of 35 
frames is created in the xsheet.

Scanning Animation Levels
Toonz supports directly some specific scanners via a USB connection by 
using Toonz internal drivers; all the other scanners are supported via 
any type of connection by using TWAIN drivers. 

Note: For an updated list of directly supported scanners, please visit 
the Toonz Web site www.toonz.com.

On Windows, in any case you need to install the TWAIN drivers provided 
with the scanner. Note that if you decide to use internal drivers, you have 
to disable the Windows Image Acquisition (WIA) service on your 
computer; if you want to use TWAIN drivers, you have to enable it.

On Macintosh, you need to install the TWAIN drivers only if you are going 
to use them. Note that if you decide to use internal drivers, any TWAIN 
driver referring to that scanner has to be removed.

Images are saved as compressed TIF or PNG files (you can choose the 
file format from the Scan File Format menu, in the Drawing tab of the 
Preferences dialog), with a progressive four-digits number written 
between the file name and the file extension, e.g. b.0001.tif, b.0002.tif, 
etc. During the scanning process image files are automatically saved in 
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the +inputs folder, i.e. the My scanned images folder as defined in the 
project settings (see Creating a New Project on page 3 for details).

Note: Sequences of files with a four-digits number written between 
the file name and the file extension are displayed in the Toonz 
browser with a double dot before the file extension, e.g. b..tif and 
bsh..tif.

To define the scanner: 
1. Choose Scan & Cleanup > Define Scanner.

2. Do one of the following:

• If your scanner is directly supported, choose Scanner Driver > 
Internal, and click the OK button.

• If your scanner is not directly supported, be sure that the necessary 
TWAIN drivers are installed, and choose Scanner Driver > TWAIN, and 
click the OK button: in the dialog that opens, select the TWAIN driver 
related to your scanner.

To scan an animation level by using a directly supported scanner:
1. Choose Scan & Cleanup > Scan Settings.

2. In the Scan Settings dialog choose the following scanning 
parameters:

• Paper Format > A4 paper.

• Activate the Paper Feeder option in case your scanner has a paper 
feeder.

• DPI > 250.

• Mode > Graytones.

• Brightness > 128.

3. Place the first drawing of the b.tlv level on the scanner flatbed, or in 
the paper feeder, choose the first frame of the b.tlv level in the xsheet, 
and choose Scan & Cleanup > Scan to scan it.

4. If the scanned image is OK, place the second drawing on the scanner 
flatbed, or all the remaining drawings on the scanner paper feeder, 
select all the other frames of the level b in the xsheet, and choose Scan 
& Cleanup > Scan to scan them. If you are using the scanner flatbed you 
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will be prompted to replace the scanned drawing with the next one to be 
scanned.

5. Follow the same steps to scan the bsh level.

To scan an animation level by using a scanner supported via TWAIN:
1. Choose Scan & Cleanup > Scan.

2. In the TWAIN interface that opens choose the following scanning 
parameters:

• Paper format > A4 paper.

• Activate the paper feeder option in case your scanner has a paper 
feeder.

• DPI > 250.

• Mode > Graytones.

3. Place the first drawing of the b.tlv level on the scanner flatbed, or in 
the paper feeder, choose the first frame of the b.tlv level in the xsheet, 
and choose the TWAIN preview command to check the result. If the 
previewed image is OK, choose the TWAIN scan command to scan it, 
otherwise change the parameters and run a preview again.
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4. Place the second drawing on the scanner flatbed, or all the 
remaining drawings on the scanner paper feeder, select all the other 
frames of the level b in the xsheet, and choose the TWAIN scan 
command to scan them. If you are using the scanner flatbed you will be 
prompted to replace the scanned drawing with the next one to be 
scanned.

5. Follow the same steps to scan the bsh level.
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Cleaning up Animation Levels

Before You Start
For this tutorial you can use the drawings scanned in the previous 
tutorial Scanning Animation Levels on page 7: you can either proceed 
directly from the scanning session, or load the scene file if you saved it, 
or load the scanned drawings in a new empty scene.

After cleaning up the drawings you can either save the scene file with the 
cleaned up drawings, or proceed to the next tutorial chapter Painting 
Animation Levels on page 21.

Note: If you did not print and scan images provided with the tutorial 
material, you can retrieve the scanned images in the Toonz TW 
Tutorial Material/Scanned Drawings folder.

To load the previously saved scene:
1. Choose File > Load Scene.

2. In the browser that opens retrieve in the My scenes folder of the 
current project the scene you want to load.

3. Click the Load button.

To load the scanned drawings in a new scene:
1. Select the xsheet cell where you want to start exposing the level.

2. Choose File > Load Level.

3. In the browser that opens retrieve and select the scanned drawing 
sequences b..tif and bsh..tif.

4. Click the Load button.

To save the scene:
1. Choose File > Save Scene As.

2. In the browser that opens select the My scenes folder of the current 
project.

3. Assign a name to the scene and click the Save button.
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Defining Cleanup Settings
Scanned lineart images have to pass through the cleanup process in 
order to be autocentered, i.e. to be set to the correct orientation and 
position according to pegbar holes, and to be prepared for the painting 
process. 

You have also to set the cleanup camera size and resolution that is used 
to crop and resize drawings during the cleanup process, in order to 
prepare and optimize them for the scene.

To define cleanup settings:
1. Choose Scan & Cleanup > Cleanup Settings.

2. In the Cleanup Settings dialog that opens set the following:

• Activate the Autocenter option, to automatically center drawings 
according to the set pegbar holes position and reference field guide (see 
below).

• Pegbar Holes > Bottom.

• Field Guide > fld_12_4mm_acme.
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To set processing parameters:
In the bottom section of the Cleanup Settings dialog you have a preview 
area: on the left side you can see the original drawing, on the right side 
there is a preview of the cleanup process. Activate the preview area 
pressing on the small eye icon at the bottom left corner, it becomes 
yellow ( ), and you can check in real time the effects of changing the 
cleanup parameters on your drawing.

In the Processing page of the Cleanup Settings set the following 
parameters:

• Brightness to 5.

• Contrast to 55.

Next to the Preview toggle there is another icon: the Opacity Check 
toggle, activate the toggle ( ).

By activating the Opacity Check fully solid pixels are displayed in black 
and semi-transparent pixels belonging to the line antialiasing in red: this 
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may helps you to decide the amount of antialiasing you want the drawing 
lines to have in order to be smoother or sharper.

Later on in this section is explained how to do this check visualizing the 
result of the cleanup process in the main Viewer.
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To set the cleanup camera:
In the Camera page of the Cleanup settings set the following camera:

• Width > 10 fld.

• Height > 7.5 fld.

• Closest > 10 fld.

• XPx > 1280.

• YPx > 960.

• A/R > 4/3.

To control the line quality and antialiasing in Scene viewer:
1. In Cleanup Settings dialog activate the Opacity Check toggle ( ).

2. In the xsheet hide the bsh column (column 2) from the work area by 
clicking the camera stand toggle ( ) in the column header, so that the b 
level hidden behind the bsh column becomes visible.

3. In the xsheet select the first frame of the b level.
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4. Choose Scan & Cleanup > Preview Cleanup to preview the process 
in the work area.
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Cleaning up Levels
The result of the cleanup process are TLV files, one file for each 
sequence of drawings (i.e. b.tlv and bsh.tlv) and TPL files for the related 
palettes. During the cleanup process TLV files are automatically saved in 
the +drawings folder, which was defined in the project settings as My 
drawings folder (see Creating a New Project on page 3 for details).

To cleanup the level drawings using the defined settings:
1. In the xsheet select all of the level frames, in both the b animation 
level and the bsh one. 

2. Choose Scan & Cleanup > Cleanup.

3. Press the Cleanup All button to execute the cleanup process on all 
the selected frames.

Note: It is also possible to save and load the defined cleanup settings 
by using the related buttons in the Cleanup Settings bottom bar: the 
settings will be saved as a CLN file.

At the end of the Cleanup process check your drawings: if you see 
scratches, marks or writings that were on the paper but are not part of 
the drawing itself, then you can refine the cleanup.

To refine the cleanup process:
1. Choose the Selection tool ( ) and activate the Modify Savebox option. 
The Savebox of the selected cell will display as a rectangle enclosing all 
the elements processed as ink by the cleanup, so even dot, scratches or 
marks that are not really part of the drawing.

2. Click and drag on the handles of the Savebox to resize it enclosig just 
the character and leaving out all the elements that are not relevant.

3. Select the next frame and repeat step 4. Do this for each frame until 
you reach the last frame.

4. Save the scene.
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Painting Animation Levels

Before You Start
For this tutorial you can use the animation levels cleaned up in the 
previous tutorial Cleaning up Animation Levels on page 13: you can 
either proceed directly from the cleanup session, or load the scene file if 
you saved it, or load the cleaned up drawings in a new empty scene.

After painting the animation levels you can save the painted levels or the 
scene file containing the painted levels, or proceed to the next tutorial 
chapter Composing the Scene on page 39.

Note: If you did not cleanup images in the previous tutorial, you can 
retrieve the cleaned up images in the Toonz TW Tutorial 
Material/Cleaned Up Drawings folder.

To load the previously saved scene:
1. Choose File > Load Scene.

2. In the browser that opens retrieve in the My scenes folder of the 
current project the scene you want to load.

3. Click the Load button.

To load the cleaned up levels in a new scene:
1. Select the xsheet cell where you want to start exposing the level.

2. Choose File > Load Level.

3. In the browser that opens retrieve and select the cleaned up 
animation levels b.tlv and bsh.tlv.

4. Click the Load button.

To save the painted levels:
1. Select any xsheet cell where the level you want to save is exposed.

2. Choose File > Save Level As.

3. In the browser that opens select the folder where you want to save 
the painted level.

4. Assign a name to the level and click the Save button.
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To save the scene with the painted levels:
1. Choose File > Save Scene As.

2. In the browser that opens select the My scenes folder of the current 
project.

3. Assign a name to the scene and click the Save button.

Defining Palette Styles
Toonz animation levels can be painted by using the styles stored in the 
palette that is automatically created when levels are cleaned up, or 
drawn directly in Toonz.

Styles can be added and edited manually, or can be defined 
automatically by loading a color model.

Note: All the modifications performed in the palettes and styles are 
not saved until you save the related Toonz level, or the palette, or the 
scene.

To change the palette display mode:
Click the option button ( ) at the bottom of the palette, and choose a 
display mode from the menu that opens among Small Thumbnail View, 
that displays styles as small squares, Large Thumbnail View, that 
displays styles on top of their name, and List View, that displays style 
thumbnails next to their names in a list.

Adding and Defining Palette Styles
Palette styles can be manually added to the palette; once added they can 
be edited by using the style editor.

To add a new style:
Click the New Style button ( ) at the bottom of the palette. 
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To edit a palette style:
Select it and use the Style Editor to edit the style. 

Loading a Color Model
Color models can be used to automatically define palette styles and 
paint the animation level.

If the color model is a Toonz raster or vector level (TLV or PLI file), it 
already comes with a palette, whose style names and page configuration 
will be preserved.

If the color model is a full-color image or animation level, the palette is 
automatically generated by extracting colors from the image, or the first 
image of the level. If the full-color image contains many shaded colors, 
the palette will be optimized to reduce the number of colors; best results 
can be achieved by preparing models painted with flat colors and whose 
outline has no anti-alias.

To load the color model for the b.tlv animation level:
1. Select any xsheet cell where the b.tlv level is exposed.

2. Do one of the following:

• Choose File > Load Color Model.

• In the Pltedit room Right-Click in the color model viewer and choose 
Load Color Model from the menu that opens.

3. In the browser that opens load the color_model.tif image you can find 
in the Toonz TW Tutorial Material/Color Models folder.
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4. In the dialog that opens choose to overwrite the destination palette: 
the palette of the b.tlv level will be replaced by the palette extracted 
from the color model.

Arranging Styles
Palette styles can be easily named, reordered and arranged in pages. 

For the b.tlv animation level you will name some styles, create new 
pages and move styles into them.

To name styles in the b.tlv level palette:
1. Click the option button ( ) at the bottom of the palette, and choose 
the Large Thumbnail View display mode that displays styles on top of 
their name.
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2. Double-click the style name to edit it.

To create pages in the b.tlv level palette:
1. Click the New Page button ( ) at the bottom of the palette three 
times to add three more pages.

2. Rename the pages to head, bust and legs by double-clicking the page 
name.

To move styles to the relevant page:
1. In the palette select all the styles used for the head areas by doing 
any of the following:

• Click a style to select it.

• Shift-click to extend the selection.

• Ctrl-click (PC) or Cmd-click (Mac) to add a style to, or remove it from 
the selection.

2. Ctrl-click (PC) or Cmd-click (Mac) and drag the selection to the tab of 
the head page.

3. Do the same for the bust and legs styles.
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Filling Areas
All Toonz drawings are made of outlines, and areas defined by outlines. 
Areas can be filled with styles as long as their outline is well-defined, 
having no gaps that occur along it. 

Options available for the Fill tool can help you to speed up the painting 
job. You can decide which options are the most suitable for your task, but 
for this tutorial the Color Model will be used to paint the first level 
drawing, the Onion Skin option to paint drawings from 2 to 5, the Frame 
Range option to paint drawings from 6 to 35, and the Selective option to 
paint all of the remaining areas of the character’s coat.

To fill an area: 
1. Select the Fill tool ( ), set the fill type to Normal and the mode to 
Areas, and select a style in the palette.

2. Do one of the following:

• Click in the area you want to fill. 
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• Click & drag crossing contiguous areas if you want to paint them with 
the same color. 

Note: If the filling color doesn’t flood the narrowest areas because of 
semitransparent pixels, try to increase the minimum Fill Depth value, 
or shift-click to use the maximum value.

Note: Use the arrow keys to navigate between the level frames while 
you are painting.

Using the Color Model
The color model can be used not only as a visual reference, but also for 
picking styles with no need to retrieve styles in the palette or to use the 
Style Picker tool ( ). 

Note: The color model can also be panned and zoomed in or out by 
using standard shortcuts.

To use the color model to fill the first drawing of the b.tlv level:
1. Select the Fill Tool, set the fill type to Normal and the mode to Areas.

2. In the color model click the area whose style you want to pick: the 
style is automatically selected.

3. Click in the drawing area you want to fill. 

4. Go on until the first drawing is completely painted.

Note: Activate the View > Transparency Check to make sure all of 
the drawings areas are properly painted. This check displays all of 
the painted areas in grey, all of the lines in black, and the background 
in white.
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Using the Onion Skin Option
The Onion Skin option available for the Fill tool ( ) lets you pick the 
style from other drawings visible in the onion skin mode, and apply it to 
the current drawing.

To display the first painted drawing in onion skin mode:
1. In the level strip select the second drawing of the b.tlv level.

2. Click the small squared markers available on the left of the current 
frame cursor, and drag it up to the first painted drawing: the drawing 
will be displayed behind the current one. 

Note: As the onion skin is related to the current frame cursor, from 
now on every time you change the current frame, the previous frame 
will be displayed in onion skin mode.

To deactivate or activate again the onion skin mode:
Click in the area on the left of the current frame cursor; click again in the 
same area to display again the onion skin.
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To automatically fill a drawing using the drawing visible in onion skin 
mode as a reference:
1. Select the Fill tool ( ), set the type to Rectangular, the mode to 
Areas, and activate the Onion Skin option. 

2. Check that the second drawing is selected in the level strip, then click 
and drag to define a box including the whole drawing to be painted: all 
the areas completely included in the box will be filled with the styles 
picked from the painted areas of the drawing displayed in onion skin 
mode.

3. Repeat the operation for drawings from 3 to 5.

Using the Frame Range Option
The Frame Range option available for the Fill tool ( ) allows you to 
perform the filling on a range of frames by clicking in the first and then 
in the last frame of the range. You can also shift-click to define the filling 
position for intermediate frames.
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To fill the same area in drawings 6-35 of the b.tlv level:
1. Select the Fill tool ( ), set the type to Normal, the mode to Areas, 
deactivate the Onion Skin option and activate only the Frame Range one. 

2. Select the hair color and click in the hair area of drawing 6: a red 
cross marker is displayed. 

3. Shift-click in the hair area of drawing14: all the hair areas in the 
drawings 6-14 range will be painted at once. 

4. Shift-click in the hair area of drawing 23: all the hair areas in the 
drawings 14-23 range will be painted at once.

5. Shift-click in the hair area of drawing 35: all the hair areas in the 
drawings 23-35 range will be painted at once.

6. Repeat the same procedure to paint the face, the trousers, the scarf 
and the hat. 

Using Different Fill Types
The Fill tool ( ) has different Type options: Rectangular can be used to 
fill all the areas included in the box you define; Freehand, to fill all the 
areas included in the area you outline by clicking and dragging; and 
Polyline, to fill all the areas included in the area you outline by defining a 
series of lines.

These options can be useful to paint small or clustered areas precisely 
with a single operation.

To paint small areas in the b.tlv level drawings:
1. Select the Fill tool ( ), set the type to Rectangular, the mode to 
Areas, and deactivate all of the other options. 

2. Select the styles used for painting the shoes, and select drawing 6.
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3. Click and drag to define a box including the shoe areas: all the areas 
will be painted.

4. Select the next drawing and go on painting the shoes.

5. Select the style used for painting the eyebrows, and select drawing 6.
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6. Set the fill type to Freehand and click and drag to define an outline 
including the eyebrow area: the eyebrow will be painted.

7. Select the next drawing and go on painting the eyebrows.

8. Repeat the same procedure to paint the eyes, the coat button, the 
teeth and the hands. 

Note: You can use keyboard shortcuts to switch from one filling type 
to another during the painting process. 

Using the Selective Option
The Selective option available for the Fill tool ( ) prevents the fill 
operation to be performed on already filled areas. 

The option can be useful to quickly fill all remaining areas in a drawing 
with the same style, such as the coat areas in the b.tlv level drawings, 
leaving the already painted areas as they are.

To fill all remaining coat areas in the b.tlv level drawings:
1. Select the Fill tool ( ), set the type to Rectangular and the mode to 
Areas, and activate the Selective and Frame Range options. 
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2. Select the styles used for painting the coat, and select drawing 6.

3. Click and drag to define a box including all of the coat areas.

4. Select drawing 35 and click and drag to define a second box: all the 
coat areas in all of the drawings will be filled with the coat style.

Filling the Shadow Level

As all of the areas in the bsh level drawings have to be painted black, you 
can paint them at once by using the Fill tool ( ) with the appropriate 
options.

To fill the bsh shadow level:
1. Select the Fill tool ( ), set the type to Rectangular and the mode to 
Areas, and activate the Frame Range option. 

2. Select the first drawing of the bsh level, and select the default black 
style.

3. Click and drag to define a box including all the shadow areas.
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4. Select drawing 35 and click and drag to define a second box: all the 
shadow areas in all the drawings will be filled with the black style.

Closing Gaps in a Drawing Outline
If you are not able to fill an area, it is very likely that the area outline is 
not perfectly defined. The gap can be closed by adding a line with the 
Brush ( ) or Geometric tool ( ), or by using the Tape tool ( ) that 
automatically joins the open ends detected in the drawing according to 
the tool settings. 

To close a gap manually:
1. Select the Brush ( ) or Geometric tool ( ), set the appropriate 
brush thickness and other options.

2. Click and drag to draw a line or the selected shape closing the gap.

To close automatically a specific gap in a drawing outline:
1. Select the Tape tool ( ), activate the Rectangular option, and set a 
distance and an angle to detect the gap.

2. Click and drag to define an area: all the gaps detected in the area 
according to the set distance and angle will be closed.
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Checking Painted Drawings
To check if all the drawing areas were properly painted, if you left some 
area unpainted, or to see if the filling left small gaps along the line 
anti-aliasing, it is useful to check the level drawings one by one.

To check if you left some areas unpainted:
Choose View > Transparency Check to highlight all the unpainted areas.

Note: The Transparency Check displays all the painted areas in grey, 
all the lines in black, and the background in white.

To fix an area left unpainted or painted with the wrong color:
Select the appropriate style and options for the Fill tool ( ) and paint 
the area that needs to be fixed.

Note: To completely remove a stye from an area leaving it unpainted 
you can use the first palette style.
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Using the Studio Palette
The studio palette allows you to store and manage an unlimited number 
of palettes. It is intended as a library of character and prop palettes 
related to one or more specific productions. 

Any level palette can be added to the studio palette; if a color model is 
defined for that level, it will be saved along with the palette and will be 
retrieved everytime that palette is assigned to a level.

Palettes added to the Toonz Palettes folder will be available in the studio 
palette in any Toonz session, regardless of the current project. 

Palettes added to the Project Palettes folder will be available only when 
the current project is the relevant one. 

To save the b.tlv level palette in the studio palette:
1. Select the b.tlv level to display its palette.

2. Do one of the following:

• Click the Palette button ( ) at the bottom of the palette and drag the 
current palette to the studio palette folder where you want to locate it.

• Add an empty palette in the studio palette browser, right-click it and 
select Replace with Level Palette from the menu that opens.

To rename the palette:
Double click its name and type a new name.

To load back the palette from the studio palette to another level palette:
1. Select the destination level to display its palette.
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2. Do one of the following:

• Click and drag the palette from the studio palette tree to the Palette 
button ( ) at the bottom of the palette.

• Right-click the palette you want to use and select Load as Level 
Palette from the menu that opens.

To merge a palette from the studio palette to another level palette:
1. Select the destination level to display its palette.

2. Do one of the following:

• Click and drag the palette from the studio palette tree to the level 
palette.

• Right-click the palette you want to use and select Merge to Level 
Palette from the menu that opens.
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Composing the Scene

Before You Start
For this tutorial you can use the animation levels painted in the previous 
tutorial Painting Animation Levels on page 21: you can either proceed 
directly from the painting session, or load the scene file if you saved it, or 
load the painted drawings in a new empty scene.

While you work on this tutorial we suggest you to save the scene from 
time to time. After you finish composing the scene you can proceed to 
the next tutorial chapter Applying Special FX on page 57.

Note: If you did not paint images in the previous tutorial, you can 
retrieve the painted images in the Toonz TW Tutorial 
Material/Painted Drawings folder.

To load the previously saved scene:
1. Choose File > Load Scene.

2. In the browser that opens retrieve in the My scenes folder of the 
current project the scene you want to load.

3. Click the Load button.

To load the painted levels in a new scene:
1. Select the xsheet cell where you want to start exposing the level.

2. Choose File > Load Level.

3. In the browser that opens retrieve and select the painted animation 
levels b.tlv and bsh.tlv.

4. Click the Load button.

To save the scene:
Do one of the following:

• Choose File > Save Scene to overwrite the previous version of the 
scene file.
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• Choose File > Save Scene As and use the browser that opens to save 
the scene in the My scenes folder of the current project as a different 
scene file with a different name.

Loading and Exposing Animation Levels
The first step when composing a scene is to load the required element. 
For this tutorial, the main character (b.tlv), his shadow (bsh.tlv), a 
background (bkg00.tif) and an overlay (overlay00.tif) have to be loaded.

By default when levels are loaded they are automatically exposed in the 
xsheet, one column for each level.

While the background and the overlay will be exposed as they are for the 
whole scene, the levels of the character and his shadow has to be 
exposed in the following way:

• They have to be exposed starting from frame 16, as they will not be 
visible at the beginning of the scene because of a camera movement (see 
below).

• Some drawings have to be exposed for several frames, when the 
character is standing still.

• All the other drawings have to be exposed at step 2, as the animation 
was planned as a step 2 animation.

• The walking cycle (drawings 26-35) has to be repeated to have the 
character walking for the final part of the scene.

To load the scene elements:
1. In a file browser, for example in the Browser room, select the Toonz 
TW Tutorial Material/Backgrounds folder: its contents are displayed on 
the right of the window.

2. Click the bkg00.tif file to select it and Ctrl-click (PC) or Cmd-click 
(Mac) the overlay00.tif file to add it to the selection.

3. Right-click any of the two selected files, choose Load from the menu 
that opens, and choose Import in the dialog box that opens: the images 
will be copied into the +extras folder of the current project, i.e. the My 
backgrounds folder, and they will be exposed in the xsheet.

4. If the b.tlv and bsh.tlv levels are not exposed in the xsheet because of 
the previous tutorial, retrieve them in the browser and load them in the 
same way you loaded the background and overlay images.

To reorder the scene elements in the xsheet:
Click and drag the area displaying the name of the column, directly 
above the column thumbnail, to reorder them bringing the background 
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to the first column, the main level to the second one, the shadow level to 
the third one and the overlay to the forth one.

To extend the exposure of the background and overlay:
1. Select the xsheet cell where the background is exposed.

2. Click and drag the fill handle, i.e. the small tab appearing at the 
bottom of the cell selection, to repeat the background up to frame 266. 
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3. Do the same for the overlay.

Note: Use the Page Down key while dragging the fill handle to scroll 
the visible frames down and fill the column in a faster way.

To edit the exposure of the b.tlv and bsh.tlv animation levels:
1. To move the exposed animation levels, click and drag to select all the 
cells where the b.tlv and bsh.tlv animation levels are exposed; then click 
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the dark vertical strip available on the left of the cells, and drag them 
down so that the drawings are first exposed at frame 16. 

2. To repeat the first drawing so that the character is standing still 
before he blinks, select the two cells where the first drawing of the b.tlv 
and bsh.tlv animation levels are exposed, then click and drag the fill 
handle, i.e. the small tab appearing at the bottom of the cell selection, to 
repeat the first drawing of each column up to frame 51. 
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3. To expose all of the remaining drawings with a step 2, select all the 
cells where drawings from 2 to 35 are exposed; then choose Cells> Step 
2.

4. To expose the drawing where the character is blinking for four 
frames, select the cells where drawing 3 is exposed; then choose 
Cells> Step 2.

5. To repeat the drawing 5 so that the character is standing still before 
the animation begins, select the cells where drawing 5 is exposed, then 
click and drag the fill handle, i.e. the small tab appearing at the bottom 
of the cell selection, to repeat the drawing 5 in each of the columns up to 
frame 80. 
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6. To repeat the walking cycle, select the cells where drawings from 26 
to 35 are exposed, choose Edit > Copy; then select the first empty cell at 
the bottom of the column, and choose Edit > Paste for seven times.

7. To remove drawings exposed in cells from frame 267 on, select them 
and choose Edit > Delete.

Animating Elements
The first element to be animated is the main character (b.tlv), that has to 
move to the left once he turns around. His shadow (bsh.tlv) will be 
moved along by linking it to the character.

Then the character’s walk will be refined by using the hook feature.

The camera will be animated as well, creating a tracking out movement 
at the beginning of the scene.

Moving the Character Level 
The character level (b.tlv) has to stand still up to frame 118, until the 
turn around movement is over and the character starts to walk.
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For this reason two key positions will be created, one at frame 119, and 
another at frame 266.

Moreover the speed of the interpolation between the two keys, that by 
default is a speed in/speed out interpolation, will be set to linear and 
with a step 2 value in order to keep it constant and to make it match the 
step of the animation.

Note: The result of this tutorial session is available in the Toonz TW 
Tutorial Material/Final Scenes project, in the scenes folder, and is 
named Composing Animation.tnz. 

To set the first key position for the main character level:
1. Select the cell of the main character’s column (column) at frame 119.

2. Choose the Edit tool ( ).

3. In the tool option bar do the following:

• Deactivate the Global Key option in order to create key values only for 
the transformations you will edit.

• Click in the E/W field and press Enter to confirm the current horizontal 
position.

• Click in the N/S field and press Enter to confirm the current vertical 
position.

To set the second key position for the main character level:
1. Select the cell of the main character’s column (column 2) at frame 
266.

2. In the tool option bar do the following:

• In the E/W field enter the value -7.8.

• In the N/S field enter the value -0.5.
46 Toonz 7.1 Harlequin - Traditional Workflow Tutorial Workbook



3. Use the framebar and the playback controls in the viewer bottom bar 
to check the result.

To control the speed of the interpolation between the two keys:
1. Choose Windows > Function Editor to open the function editor.

2. In the object tree on the left open the Stage > b (Col 2) folder, where 
the transformation curves of the column 2 are available.

3. Select the E/W item to display the related curve in the area on the 
right; click in the area and press the 0 key to fit the selected curve to the 
area.

4. Click the curve to select it.
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5. At the bottom of the curve area change the Interpolation from Speed 
In / Speed Out to Linear, and set the Step to 2.

6. Do the same for the N/S curve.

Note: If the right area of the function editor is displaying numerical 
columns, click the Function Editor Toggle button ( ) at the bottom of 
the area to display curves.

Linking the Shadow Level
To move the shadow level (bsh.tlv) along with the character, the related 
columns will be linked in the Schematic window. This way any editing on 
the movement of the main character column will affect the shadow as 
well.

To link the shadow column to the character column:
1. Choose Windows > Schematic to open the stage schematic.
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2. In the stage, click and drag the left port of the bsh column node to the 
right port of the b column node.

3. Use the framebar and the playback controls in the viewer bottom bar 
to check the result.

Note: If the schematic is displaying FX nodes, click the Schematic 
Toggle button ( ) at the bottom of the window to display the stage.

Using Hooks
When animating a walking animation cycle it is likely that the character 
is going to glide on the background while moving from one key position 
to another. 

To prevent this effect it is possible to use the Hook tool ( ) to create a 
reference point (i.e. a hook) that tracks the feet position, passing from 
one foot to the other, and make the level move according to it.
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In this section of the tutorial the previously defined animation will be 
deleted, and a hook set will be created for the b.tlv animation level. Later 
on this hook set will be used to move the character.

Note: The result of this tutorial session is available in the Toonz TW 
Tutorial Material/Final Scenes project, in the scenes folder, and is 
named Composing Hook.tnz. 

To remove the previously defined animation for the b.tlv level:
1. Click the key icon that is visible at frame 119 in column 2 to select it.

2. Shift-click the key icon that is visible at frame 266 in column 2 to add 
it to the selection.

3. Choose Edit > Delete.

To define a hook set for the b.tlv level: 
1. Select any xsheet cell where the b.tlv level is exposed.

1. Select the first frame of the level in the level strip.

2. Choose the Hook tool ( ).
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3. In the work area click to create a hook set and drag it to place it at the 
tip of the heel of the character’s right foot.

4. As for the first 25 frames the character is turning, in all those frames 
leave the hook as it is, so that at frame 25 the hook is placed under the 
heel of the character’s left foot.

5. At frame 26 Shift-drag the hook to reposition it under the heel of the 
character’s left foot, while constraining the movement horizontally.

6. From frame 27 to 30 continue to reposition the hook by shifting it 
horizontally according to the heel of the character’s left foot.

Note: When the foot leaves the ground, place the hook as if it was a 
footprint left on the ground

7. At frame 30 pass the hook from one foot to the other by Alt-clicking 
the hook and splitting it in two; then leave the circle under the heel of 
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the character’s left foot, and place the cross under the heel of the 
character’s right foot.

8. From frame 31 to 34 continue to reposition the hook by shifting it 
horizontally according to the heel of the character’s right foot.

9. At frame 34 pass again the hook from one foot to the other by 
Alt-clicking the hook and splitting it in two; then leave the circle under 
the heel of the character’s right foot, and place the cross under the heel 
of the character’s left foot.

10.At frame 35 Shift-drag the hook to reposition it under the heel of the 
character’s left foot, while constraining the movement horizontally. 

Note: You can click on the vertical ruler to set a horizontal guide as a 
reference for repositioning the hook.

To move the character by using the defined hook:
1. Choose Windows > Schematic to open the stage schematic.
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2. Place the pointer on the left port of the b column node and wait for 
the double-arrow button to appear.

3. Click and drag up the double-arrow button to replace the B with 1, 
which is the hook set 1: in the viewer the b.tlv level will shift so that hook 
1 is placed at the center of the work area.

Note: If the schematic is displaying FX nodes, click the Schematic 
Toggle button ( ) at the bottom of the window to display the stage.

4. Select the b column at frame 16, then choose the Edit tool ( ) and 
set the starting position for the b column by doing one of the following:

• Click in the work area and drag the column to its starting position.

• In tool option bar enter the value -3.2 in the N/S field.

5. Use the framebar and the playback controls in the viewer bottom bar 
to check the result.

Animating the Camera
The camera can be animated like any other element of the scene, with a 
truck out movement in the first section of the scene.
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The speed of the movement will be controlled by using the function 
editor, where all the transformations involved in the camera truck out 
(horizontal movement, vertical movement and global scale) will be 
edited at the same time.

To check the final result you will also switch to camera view mode, which 
keeps the box representing the camera still, while all the other elements 
move in relation to its position.

Note: The result of this tutorial session is available in the Toonz TW 
Tutorial Material/Final Scenes project, in the scenes folder, and is 
named Composing.tnz. 

To animate the camera:
1. Choose Windows > Schematic to open the stage schematic, and 
select the camera node.

Note: If the schematic is displaying FX nodes, click the Schematic 
Toggle button ( ) at the bottom of the window to display the stage.

2. In the xsheet frame column select frame 16: this is the first frame 
where the camera will have a key position.

3. Choose the Edit tool ( ) and in the tool option bar do the following:

• In the E/W field enter the value 3.

• In the N/S field enter the value -0.3.
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4. In the scale Global field enter the value 30%.

5. In the xsheet frame column select frame 46: this is the second frame 
where the camera will have a key position.

6. In the tool option bar do the following:

• In the E/W field enter the value 0.

• In the N/S field enter the value 0.

• In the Scale Global field enter the value 100%.

To set the speed of the camera movement:
1. Choose Windows > Function Editor to open the function editor.

2. In the object tree on the left open the Stage > Camera folder, where 
the transformation curves of the camera are available.

3. Select the E/W, N/S and Scale items to display the related curves in 
the area on the right; click in the area and press the 0 key to fit the 
selected curve to the area.
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4. In the strip at the top of the window, below the frame ruler, do the 
following:

• Click and drag the marker available on the right of the first key point 
and set the Speed In value to 4.

• Click and drag the marker available on the left of the first key point 
and set the Speed Out value to -20.

Note: If the right area of the function editor is displaying numerical 
columns, click the Function Editor Toggle button ( ) at the bottom of 
the area to display curves.

To check the final animation in camera view mode:
1. Click the Camera View button ( ) in the viewer title bar.

2. Use the framebar and the playback controls in the viewer bottom bar 
to check the result.
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Applying Special FX

Before You Start
For this tutorial you can use the scene created in the previous tutorial 
Composing the Scene on page 39: you can either proceed directly from 
the composing session, or load the scene file you saved.

While you work on this tutorial we suggest you to save the scene from 
time to time. After you finish applying special FX you can proceed to the 
next tutorial chapter Rendering the Animation on page 67.

Note: If you did not complete the previous tutorial, you can retrieve 
the final scene file in the Toonz TW Tutorial Material/Final Scenes 
project, in the scenes folder, named as Composing.tnz. 

To load the previously saved scene:
1. Choose File > Load Scene.

2. In the browser that opens retrieve in the My scenes folder of the 
current project the scene you want to load.

3. Click the Load button.

To save the scene:
Do one of the following:

• Choose File > Save Scene to overwrite the previous version of the 
scene file.

• Choose File > Save Scene As and use the browser that opens to save 
the scene in the My scenes folder of the current project as a different 
scene file with a different name.

Applying Special FX to the Main Character
To improve the appearance of the main character and integrate it better 
with the background, some special FX will be added.

The character’s colors will be darkened with a Brightness Contrast 
effect, and a yellow highlight will be added along the upper outline with a 
Body Highlight effect.
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The shadow level will be softened by using a Transparency and a Blur 
effect.

The special FX will not change during the animation: this means that the 
values you set will be valid throughout the scene.

Note: The result of this tutorial session is available in the Toonz TW 
Tutorial Material/Final Scenes project, in the scenes folder, and is 
named Special FX.tnz. 

To darken the character’s colors:
1. In the xsheet frame column select a frame where the main character 
is visible (from frame 16 on).

2. Choose Windows > Schematic to open the stage schematic, and 
click the Schematic Toggle button ( ) at the bottom of the window to 
display the FX schematic.

3. Right-click the b column node and choose Insert FX > Image Adjust 
> Brightness Contrast from the menu that opens: a Brightness 
Contrast effect node in inserted between the column node and the 
xsheet one.

4. Double-click the Brightness Contrast effect node: the FX Settings 
window opens.
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5. In the FX Settings window click the Preview button ( ) available in 
the bottom bar to activate the preview area, and set the Brightness value 
to -55 and leave the Contrast to 0.

6. Click the Preview button ( ) in the viewer title bar to activate the 
preview mode and use the framebar and the playback controls in the 
viewer bottom bar to check the result within the full scene.

To create the character’s body highlight:
1. In the schematic right-click the Brightness Contrast effect node and 
choose Insert FX > Light > Body Highlight from the menu that opens: a 
Body Highlight effect node in inserted between the Brightness Contrast 
effect node and the xsheet one.

2. Click the Body Highlight effect node: the FX Settings window displays 
the related settings.

3. Set the following values: 

• Offset X > 0.

• Offset Y > 4.2.

• Transparency > 0.5.

• Blur > 2.
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• Color > R 255, G 232, B 128.

4. Click the Preview button ( ) in the viewer title bar to activate the 
preview mode and use the framebar and the playback controls in the 
viewer bottom bar to check the result in the full scene.

To soften the shadow level:
1. In the FX Schematic right-click the bsh column node and choose 
Insert FX > Layer Blending > Transparency from the menu that opens: 
a Transparency effect node in inserted between the column node and the 
xsheet one.

2. In the FX Settings window set the transparency intensity value to 40.

3. In the FX Schematic right-click the Transparency effect node and 
choose Insert FX > Blur > Blur from the menu that opens: a Blur effect 
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node is inserted between the Transparency effect node and the xsheet 
one.

4. In the FX Settings window set the blur value to 2.

5. Click the Preview button ( ) in the viewer title bar to activate the 
preview mode and use the framebar and the playback controls in the 
viewer bottom bar to check the result within the full scene.

Adding Light FX to the Background
To add some light halos around the moon and the lanterns of the 
background image, you will add some radial gradients.

For the lanterns the gradients will be animated using an expression in 
the function editor in order to simulate a vibrating light. The expression 
will be a periodic function using in one case the sine value and the other 
the cosine one in order to have two unsynchronized lights. 

Note: Gradient FX are computer-generated images that are exposed 
in xsheet columns and therefore are similar to columns. 

Note: The result of this tutorial session is available in the Toonz TW 
Tutorial Material/Final Scenes project, in the scenes folder, and is 
named Special FX.tnz. 

To add a light halo to the moon:
1. Select column 2 in the xsheet at frame 1, as the gradient has to be 
inserted between the background and the character columns starting 
from frame 1.
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2. Right-click anywhere in the FX Schematic and choose Add FX > 
Gradient > Radial Gradient from the menu that opens: a Radial Gradient 
effect node is added in the schematic and a column containing the 
gradient is inserted in the xsheet.

3. In the FX Settings window set the following values for the gradient 
colors: 

• Color 1 > R 255, G 255, B 255, A 200;

• Color 2 > R 255, G 255, B 255, A 0.

4. To set the gradient position and size choose the Edit tool ( ) and do 
the following:

• Click and drag anywhere in the work area to center the gradient on the 
moon.

• Click and drag the blue circle to set the outer size of the gradient.
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• Click and drag the blue dot close to the center to set the inner size of 
the gradient.

5. Click the Preview button ( ) in the viewer title bar to activate the 
preview mode and use the framebar and the playback controls in the 
viewer bottom bar to check the result in the full scene.

To add a light halo to each of the lanterns:
1. Add two more radial gradients in the FX Schematic, and set for both 
of them the following colors:

• Color 1 > R 255, G 220, B 0, A 200;
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• Color 2 > R 255, G 220, B 0, A 0.

2. Select the gradient nodes and use the Edit tool ( ) to set the 
gradient position and size.
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3. Click the Preview button ( ) in the viewer title bar to activate the 
preview mode and use the framebar and the playback controls in the 
viewer bottom bar to check the result within the full scene.

To animate the halo of the lanterns by using an expression:
1. Choose Windows > Function Editor to open the function editor.

2. In the FX tree on the left open the FX > Radial Gradient 2 > Color 1 
folder, where the transformation curves for the red, green, blue and 
alpha components of the color 1 are available.

Note: If the right area of the function editor is displaying numerical 
columns, click the Function Editor Toggle button ( ) at the bottom of 
the area to display curves.

3. Click the Alpha item label to display and select the related curve in 
the area on the right: the curve is a dotted line at the value 200 as no 
transformation is defined yet.

4. Move the framebar to frame 1, and define a key value by clicking the 
Set Key button ( ) at the bottom of the window; then move the 
framebar to frame 266 and define another key.

5. Click the segment between the keys you just defined to select it, and 
at the bottom of the curve area change the Interpolation from Speed In / 
Speed Out to Expression.
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6. In the Expression field type the following expression:

200+10*sin(f*30)

where 200 is the basic value of the periodic function, 10 sets the period 
amplitude, 30 sets its frequency, and f is the frame variable.

7. Follow the same procedure for the Radial Gradient 3 > Color 1 > 
Alpha curve, but this time use the following expression.

200+10*cos(f*30)

8. Click the Preview button ( ) in the viewer title bar to activate the 
preview mode and use the framebar and the playback controls in the 
viewer bottom bar to check the result within the full scene.
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Rendering the Animation

Before You Start
For this tutorial you can use the scene created in the previous tutorial 
Applying Special FX on page 57: you can either proceed directly from the 
FX session, or load the scene file you saved.

Note: If you did not complete the previous tutorial, you can retrieve 
the final scene file in the Toonz TW Tutorial Material/Final Scenes 
project, in the scenes folder, named as Special FX.tnz. 

To load the previously saved scene:
1. Choose File > Load Scene.

2. In the browser that opens retrieve in the My scenes folder of the 
current project the scene you want to load.

3. Click the Load button.

Rendering the Animation
In order to generate the final animation including all the transformations 
and special FX applied to the scene elements, the scene has to be 
rendered.

Renderings can be run directly from a loaded scene, or in batch mode. In 
both cases the rendering properties are defined in the Output Settings 
dialog.

Defining the Output Settings
The Output Settings dialog lets you define the file format, location and 
properties for the final rendering. 

To set the output format for the loaded scene:
1. Choose File > Output Settings: the Output Settings window opens.

2. Check that the Save in value is +outputs, that is to say the default 
folder you defined for the current project, i.e. the My renderings folder 
(see Creating a New Project on page 3 for details).
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3. In the File Format option menu choose the MOV format; click the 
Options button to open a dialog to set format properties, such as the 
codec to be used.

4. Save the scene.

Rendering the Loaded Scene
The current scene can be rendered directly while being loaded in Toonz 
according to the defined output settings.

To render the currently loaded scene:
Choose File > Render: a progress bar opens, and at the end of the 
process the rendered animation will be automatically displayed in a 
Toonz flipbook.

Rendering the Scene in Batch Mode
The rendering of a scene can be added to a task list and performed in 
batch mode in order to run it in the background while you perform other 
works on your computer. 

Render tasks are submitted, managed and executed in the Tasks pane.

When the tasks are executed, the icon color tells the status of the task 
according to the following color code:

• Grey when the task is waiting or is not executed yet.

• Yellow when the task is being executed.

• Green when the task is successfully executed.
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• Orange when the task is submitted and in queue.

• Red when the task execution is failed.

To add scenes to render in the task list:
Click the Add Render Task button ( ) at the bottom of the Tasks pane 
and use the browser to retrieve the scene file in the My scenes folder.

To execute the rendering:
1. Click the scene in the task list to select it.

2. Click the Start button ( ) at the bottom of the pane: the scene starts 
being rendered in the format and in the folder specified in the output 
settings.
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